Cannot use USB devices on Virtualbox 2 in Intrepid

There is a quick fix if you get some USB related errors when opening Preferences in Virtualbox 2.
You only have to add these lines in your /etc/fstab file:

# usbfs
none /proc/bus/usb usbfs devgid=46,devmode=664 0 0
  1. didnt work for me with vbox 2.0.4 in intrepid

    i also did:

    grep vbox /etc/group

    and i got correct number for devgid but that didnt work either.

    i even tried with:

    none /proc/bus/usb usbfs devgid=$TTYGRP,devmode=$TTYMODE

    in a desperate search for the solution, but nothing worked.

    thanks anyways

  2. It worked for me, thanks 🙂

  3. using the id from
    > grep vbox /etc/group
    in /etc/fstab
    worked for me! thx!
    ___

    > uname -a
    Linux xps 2.6.26-1-686 #1 SMP Fri Mar 13 18:08:45 UTC 2009 i686 GNU/Linux

    from
    > dpkg -s virtualbox-2.1
    […]Version: 2.1.4-42893_Debian_lenny

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

This site uses Akismet to reduce spam. Learn how your comment data is processed.

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close