No LFE (Low-Frequency Effects) in Ubuntu 9.04 (Jaunty Jackalope)

There is a new catch if you want to enable 5.1 surround sound in Ubuntu 9.04. First you need to follow the same steps like you did for Hardy Heron. There is an old post I wrote about it.
In this new version of PulseAudio they don’t synthesize an LFE signal anymore by default.
They introduced this new option called disable-lfe-remixing.

When upmixing or downmixing ignore LFE channels. When this option is on the output LFE channel will only get a signal when an input LFE channel is available as well. If no input LFE channel is available the output LFE channel will always be 0. If no output LFE channel is available the signal on the input LFE channel will be ignored. Defaults to “on”.

The solution to get you bass back is to set this option to no.
As a result, here are the steps you need to take:

sudo joe /etc/pulse/daemon.conf

Uncomment the line containing:

default-sample-channels = 2

and replace '2' with '6' (if you have a 7.1 card, replace '2' with '8').
Next, set disable-lfe-remixing option to no

disable-lfe-remixing = no

Restart your computer and you’re in business.
NOTE: Documentation for this article is taken from here and here.

  1. Thanks for the post!
    and the day is saved..

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close